apache-ignite_2.8.0-1_all.deb package has older version of openjdk as dependency

classic Classic list List threaded Threaded
17 messages Options
rakshita04 rakshita04
Reply | Threaded
Open this post in threaded view
|

apache-ignite_2.8.0-1_all.deb package has older version of openjdk as dependency

Hi Team,

We are using apache-ignite for our C++ application based on debian
10(buster). We tried using apache-ignite_2.8.0-1_all.deb package but it
depends on openjdk-8 which is older version and not available for debian 10
buster. I have below questions-
1. Why older version of openjdk is used in deb package?
2. Is there any possibility of new released version of deb package with
source apache-ignite_2.8.0 with newer openjdk version?



--
Sent from: http://apache-ignite-users.70518.x6.nabble.com/
Petr Ivanov Petr Ivanov
Reply | Threaded
Open this post in threaded view
|

Re: apache-ignite_2.8.0-1_all.deb package has older version of openjdk as dependency

I guess it can be targeted to 2.8.1 if there any scope space left.


> On 6 May 2020, at 07:27, rakshita04 <[hidden email]> wrote:
>
> Hi Team,
>
> We are using apache-ignite for our C++ application based on debian
> 10(buster). We tried using apache-ignite_2.8.0-1_all.deb package but it
> depends on openjdk-8 which is older version and not available for debian 10
> buster. I have below questions-
> 1. Why older version of openjdk is used in deb package?
> 2. Is there any possibility of new released version of deb package with
> source apache-ignite_2.8.0 with newer openjdk version?
>
>
>
> --
> Sent from: http://apache-ignite-users.70518.x6.nabble.com/

rakshita04 rakshita04
Reply | Threaded
Open this post in threaded view
|

Re: apache-ignite_2.8.0-1_all.deb package has older version of openjdk as dependency

Thanks Petr.
When can we expect 2.8.1 .deb package with newer openjdk dependency?



--
Sent from: http://apache-ignite-users.70518.x6.nabble.com/
ilya.kasnacheev ilya.kasnacheev
Reply | Threaded
Open this post in threaded view
|

Re: apache-ignite_2.8.0-1_all.deb package has older version of openjdk as dependency

Hello!

Come to think of it, maybe we can just depend on java-sdk meta-package?

Can you file an IGNITE JIRA ticket about that?

Regards,
--
Ilya Kasnacheev


ср, 6 мая 2020 г. в 11:58, rakshita04 <[hidden email]>:
Thanks Petr.
When can we expect 2.8.1 .deb package with newer openjdk dependency?



--
Sent from: http://apache-ignite-users.70518.x6.nabble.com/
rakshita04 rakshita04
Reply | Threaded
Open this post in threaded view
|

Re: apache-ignite_2.8.0-1_all.deb package has older version of openjdk as dependency

are you talking about oracle-java8-installer? mentioned in control file of
your package?
actually we are able to manually compile platform/cpp code using openjdk-11.
So wanted to check with you if there is any specific reason for using
openjdk-8 for .deb released package?




--
Sent from: http://apache-ignite-users.70518.x6.nabble.com/
ilya.kasnacheev ilya.kasnacheev
Reply | Threaded
Open this post in threaded view
|

Re: apache-ignite_2.8.0-1_all.deb package has older version of openjdk as dependency

Hello!

There is no reason to depend on Java 8 specifically.

Regards,
--
Ilya Kasnacheev


ср, 6 мая 2020 г. в 15:27, rakshita04 <[hidden email]>:
are you talking about oracle-java8-installer? mentioned in control file of
your package?
actually we are able to manually compile platform/cpp code using openjdk-11.
So wanted to check with you if there is any specific reason for using
openjdk-8 for .deb released package?




--
Sent from: http://apache-ignite-users.70518.x6.nabble.com/
rakshita04 rakshita04
Reply | Threaded
Open this post in threaded view
|

Re: apache-ignite_2.8.0-1_all.deb package has older version of openjdk as dependency

Can we have the newer debian package for apache ignite with newer version of
openjdk as dependencies?



--
Sent from: http://apache-ignite-users.70518.x6.nabble.com/
ilya.kasnacheev ilya.kasnacheev
Reply | Threaded
Open this post in threaded view
|

Re: apache-ignite_2.8.0-1_all.deb package has older version of openjdk as dependency

Hello!

You can build debian package from apache-ignite source deliverable. There you can fix the dependency.

Regards,
--
Ilya Kasnacheev


ср, 27 мая 2020 г. в 11:51, rakshita04 <[hidden email]>:
Can we have the newer debian package for apache ignite with newer version of
openjdk as dependencies?



--
Sent from: http://apache-ignite-users.70518.x6.nabble.com/
Artem Budnikov Artem Budnikov
Reply | Threaded
Open this post in threaded view
|

Re: apache-ignite_2.8.0-1_all.deb package has older version of openjdk as dependency

Looks like this issue wasn't fixed in 2.8.1. The Ignite deb package v. 2.8.1 can't be installed on debian 10:

$ sudo apt-get install apache-ignite
...
The following packages have unmet dependencies:
 apache-ignite : Depends: openjdk-8-jdk but it is not installable or
                        oracle-java8-installer but it is not installable
E: Unable to correct problems, you have held broken packages.

Is anyone working on this? I was going to update the Ignite 2.9 installation instruction for Debian, but if the issue is staying with us, I guess I shouldn't bother.

-Artem

On 27.05.2020 11:55, Ilya Kasnacheev wrote:
Hello!

You can build debian package from apache-ignite source deliverable. There you can fix the dependency.

Regards,
--
Ilya Kasnacheev


ср, 27 мая 2020 г. в 11:51, rakshita04 <[hidden email]>:
Can we have the newer debian package for apache ignite with newer version of
openjdk as dependencies?



--
Sent from: http://apache-ignite-users.70518.x6.nabble.com/
Petr Ivanov Petr Ivanov
Reply | Threaded
Open this post in threaded view
|

Re: apache-ignite_2.8.0-1_all.deb package has older version of openjdk as dependency

Hi, Artem,


Can you file and issue with description what exactly do not work and why, please?


On 27 Aug 2020, at 11:55, Artem Budnikov <[hidden email]> wrote:

Looks like this issue wasn't fixed in 2.8.1. The Ignite deb package v. 2.8.1 can't be installed on debian 10:


$ sudo apt-get install apache-ignite
...
The following packages have unmet dependencies:
 apache-ignite : Depends: openjdk-8-jdk but it is not installable or
                        oracle-java8-installer but it is not installable
E: Unable to correct problems, you have held broken packages.


Is anyone working on this? I was going to update the Ignite 2.9 installation instruction for Debian, but if the issue is staying with us, I guess I shouldn't bother.

-Artem

On 27.05.2020 11:55, Ilya Kasnacheev wrote:
Hello!

You can build debian package from apache-ignite source deliverable. There you can fix the dependency.

Regards,
--
Ilya Kasnacheev


ср, 27 мая 2020 г. в 11:51, rakshita04 <[hidden email]>:
Can we have the newer debian package for apache ignite with newer version of
openjdk as dependencies?



--
Sent from: http://apache-ignite-users.70518.x6.nabble.com/

Artem Budnikov Artem Budnikov
Reply | Threaded
Open this post in threaded view
|

Re: apache-ignite_2.8.0-1_all.deb package has older version of openjdk as dependency

I've created a JIRA issue: https://issues.apache.org/jira/browse/IGNITE-13388

-Artem

On 27.08.2020 12:05, Petr Ivanov wrote:
Hi, Artem,


Can you file and issue with description what exactly do not work and why, please?


On 27 Aug 2020, at 11:55, Artem Budnikov <[hidden email]> wrote:

Looks like this issue wasn't fixed in 2.8.1. The Ignite deb package v. 2.8.1 can't be installed on debian 10:


$ sudo apt-get install apache-ignite
...
The following packages have unmet dependencies:
 apache-ignite : Depends: openjdk-8-jdk but it is not installable or
                        oracle-java8-installer but it is not installable
E: Unable to correct problems, you have held broken packages.


Is anyone working on this? I was going to update the Ignite 2.9 installation instruction for Debian, but if the issue is staying with us, I guess I shouldn't bother.

-Artem

On 27.05.2020 11:55, Ilya Kasnacheev wrote:
Hello!

You can build debian package from apache-ignite source deliverable. There you can fix the dependency.

Regards,
--
Ilya Kasnacheev


ср, 27 мая 2020 г. в 11:51, rakshita04 <[hidden email]>:
Can we have the newer debian package for apache ignite with newer version of
openjdk as dependencies?



--
Sent from: http://apache-ignite-users.70518.x6.nabble.com/

Petr Ivanov Petr Ivanov
Reply | Threaded
Open this post in threaded view
|

Re: apache-ignite_2.8.0-1_all.deb package has older version of openjdk as dependency

In reply to this post by rakshita04
Hi!


As a temporary workaround, please see this article [1].
Meanwhile, I will try to figure out how to create more generalised JDK dependency.



[1] https://stackoverflow.com/questions/57031649/how-to-install-openjdk-8-jdk-on-debian-10-buster


> On 6 May 2020, at 07:27, rakshita04 <[hidden email]> wrote:
>
> Hi Team,
>
> We are using apache-ignite for our C++ application based on debian
> 10(buster). We tried using apache-ignite_2.8.0-1_all.deb package but it
> depends on openjdk-8 which is older version and not available for debian 10
> buster. I have below questions-
> 1. Why older version of openjdk is used in deb package?
> 2. Is there any possibility of new released version of deb package with
> source apache-ignite_2.8.0 with newer openjdk version?
>
>
>
> --
> Sent from: http://apache-ignite-users.70518.x6.nabble.com/

Petr Ivanov Petr Ivanov
Reply | Threaded
Open this post in threaded view
|

Re: apache-ignite_2.8.0-1_all.deb package has older version of openjdk as dependency

https://issues.apache.org/jira/browse/IGNITE-13388 is ready for review.
Iliya, can you help with it?



On 27 Aug 2020, at 12:26, Petr Ivanov <[hidden email]> wrote:

Hi!


As a temporary workaround, please see this article [1].
Meanwhile, I will try to figure out how to create more generalised JDK dependency.



[1] https://stackoverflow.com/questions/57031649/how-to-install-openjdk-8-jdk-on-debian-10-buster


On 6 May 2020, at 07:27, rakshita04 <[hidden email]> wrote:

Hi Team,

We are using apache-ignite for our C++ application based on debian
10(buster). We tried using apache-ignite_2.8.0-1_all.deb package but it
depends on openjdk-8 which is older version and not available for debian 10
buster. I have below questions-
1. Why older version of openjdk is used in deb package?
2. Is there any possibility of new released version of deb package with
source apache-ignite_2.8.0 with newer openjdk version?



--
Sent from: http://apache-ignite-users.70518.x6.nabble.com/


ilya.kasnacheev ilya.kasnacheev
Reply | Threaded
Open this post in threaded view
|

Re: apache-ignite_2.8.0-1_all.deb package has older version of openjdk as dependency

Hello!

I have replied in the PR.

Regards,
--
Ilya Kasnacheev


чт, 27 авг. 2020 г. в 17:26, Petr Ivanov <[hidden email]>:
https://issues.apache.org/jira/browse/IGNITE-13388 is ready for review.
Iliya, can you help with it?



On 27 Aug 2020, at 12:26, Petr Ivanov <[hidden email]> wrote:

Hi!


As a temporary workaround, please see this article [1].
Meanwhile, I will try to figure out how to create more generalised JDK dependency.



[1] https://stackoverflow.com/questions/57031649/how-to-install-openjdk-8-jdk-on-debian-10-buster


On 6 May 2020, at 07:27, rakshita04 <[hidden email]> wrote:

Hi Team,

We are using apache-ignite for our C++ application based on debian
10(buster). We tried using apache-ignite_2.8.0-1_all.deb package but it
depends on openjdk-8 which is older version and not available for debian 10
buster. I have below questions-
1. Why older version of openjdk is used in deb package?
2. Is there any possibility of new released version of deb package with
source apache-ignite_2.8.0 with newer openjdk version?



--
Sent from: http://apache-ignite-users.70518.x6.nabble.com/


Petr Ivanov Petr Ivanov
Reply | Threaded
Open this post in threaded view
|

Re: apache-ignite_2.8.0-1_all.deb package has older version of openjdk as dependency

Thanks!


Applied your suggestions.

On 7 Sep 2020, at 16:45, Ilya Kasnacheev <[hidden email]> wrote:

Hello!

I have replied in the PR.

Regards,
--
Ilya Kasnacheev


чт, 27 авг. 2020 г. в 17:26, Petr Ivanov <[hidden email]>:
https://issues.apache.org/jira/browse/IGNITE-13388 is ready for review.
Iliya, can you help with it?



On 27 Aug 2020, at 12:26, Petr Ivanov <[hidden email]> wrote:

Hi!


As a temporary workaround, please see this article [1].
Meanwhile, I will try to figure out how to create more generalised JDK dependency.



[1] https://stackoverflow.com/questions/57031649/how-to-install-openjdk-8-jdk-on-debian-10-buster


On 6 May 2020, at 07:27, rakshita04 <[hidden email]> wrote:

Hi Team,

We are using apache-ignite for our C++ application based on debian
10(buster). We tried using apache-ignite_2.8.0-1_all.deb package but it
depends on openjdk-8 which is older version and not available for debian 10
buster. I have below questions-
1. Why older version of openjdk is used in deb package?
2. Is there any possibility of new released version of deb package with
source apache-ignite_2.8.0 with newer openjdk version?



--
Sent from: http://apache-ignite-users.70518.x6.nabble.com/



ilya.kasnacheev ilya.kasnacheev
Reply | Threaded
Open this post in threaded view
|

Re: apache-ignite_2.8.0-1_all.deb package has older version of openjdk as dependency

Thank you for the fix!

+ alex
I wonder if it can be included in 2.9. It's an one-liner in package build script. I'll do it if you acknowledge.

Regards,
--
Ilya Kasnacheev


пн, 7 сент. 2020 г. в 17:29, Petr Ivanov <[hidden email]>:
Thanks!


Applied your suggestions.

On 7 Sep 2020, at 16:45, Ilya Kasnacheev <[hidden email]> wrote:

Hello!

I have replied in the PR.

Regards,
--
Ilya Kasnacheev


чт, 27 авг. 2020 г. в 17:26, Petr Ivanov <[hidden email]>:
https://issues.apache.org/jira/browse/IGNITE-13388 is ready for review.
Iliya, can you help with it?



On 27 Aug 2020, at 12:26, Petr Ivanov <[hidden email]> wrote:

Hi!


As a temporary workaround, please see this article [1].
Meanwhile, I will try to figure out how to create more generalised JDK dependency.



[1] https://stackoverflow.com/questions/57031649/how-to-install-openjdk-8-jdk-on-debian-10-buster


On 6 May 2020, at 07:27, rakshita04 <[hidden email]> wrote:

Hi Team,

We are using apache-ignite for our C++ application based on debian
10(buster). We tried using apache-ignite_2.8.0-1_all.deb package but it
depends on openjdk-8 which is older version and not available for debian 10
buster. I have below questions-
1. Why older version of openjdk is used in deb package?
2. Is there any possibility of new released version of deb package with
source apache-ignite_2.8.0 with newer openjdk version?



--
Sent from: http://apache-ignite-users.70518.x6.nabble.com/



Petr Ivanov Petr Ivanov
Reply | Threaded
Open this post in threaded view
|

Re: apache-ignite_2.8.0-1_all.deb package has older version of openjdk as dependency

Iliya, thanks for the review/merge.


Rakshita, you can use patch on 2.8.1 branch/tag and rebuild deb that will suites you or indeed wait for 2.9.0 if it will be included.



On 7 Sep 2020, at 18:57, Ilya Kasnacheev <[hidden email]> wrote:

Thank you for the fix!

+ alex
I wonder if it can be included in 2.9. It's an one-liner in package build script. I'll do it if you acknowledge.

Regards,
--
Ilya Kasnacheev


пн, 7 сент. 2020 г. в 17:29, Petr Ivanov <[hidden email]>:
Thanks!


Applied your suggestions.

On 7 Sep 2020, at 16:45, Ilya Kasnacheev <[hidden email]> wrote:

Hello!

I have replied in the PR.

Regards,
--
Ilya Kasnacheev


чт, 27 авг. 2020 г. в 17:26, Petr Ivanov <[hidden email]>:
https://issues.apache.org/jira/browse/IGNITE-13388 is ready for review.
Iliya, can you help with it?



On 27 Aug 2020, at 12:26, Petr Ivanov <[hidden email]> wrote:

Hi!


As a temporary workaround, please see this article [1].
Meanwhile, I will try to figure out how to create more generalised JDK dependency.



[1] https://stackoverflow.com/questions/57031649/how-to-install-openjdk-8-jdk-on-debian-10-buster


On 6 May 2020, at 07:27, rakshita04 <[hidden email]> wrote:

Hi Team,

We are using apache-ignite for our C++ application based on debian
10(buster). We tried using apache-ignite_2.8.0-1_all.deb package but it
depends on openjdk-8 which is older version and not available for debian 10
buster. I have below questions-
1. Why older version of openjdk is used in deb package?
2. Is there any possibility of new released version of deb package with
source apache-ignite_2.8.0 with newer openjdk version?



--
Sent from: http://apache-ignite-users.70518.x6.nabble.com/