Which Ignite AWS library will support spark 3.0.1 and scala 2.12.12 versions based application?

classic Classic list List threaded Threaded
2 messages Options
ChandanS ChandanS
Reply | Threaded
Open this post in threaded view
|

Which Ignite AWS library will support spark 3.0.1 and scala 2.12.12 versions based application?

This post was updated on .
Hi All,

Can anyone please let me know which apache or grid-gain ignite library for
AWS EC2 instance deployment will support AWS EMR spark application with
spark-3.0.1 and scala-2.12.12 version to access the ignite cache launched in
AWS EC2 instances from EMR spark job?

Currently, I am using "gridgain-community-8.8.1" library, but it supports
EMR spark job with spark-2.4.4 and scala-2.11.12. It's not working with my
required spark-3.0.1 and scala-2.12.12 versions.

Any help or suggestion will be highly appreciated.


Thanks,
Chandan



--
Sent from: http://apache-ignite-users.70518.x6.nabble.com/
aealexsandrov aealexsandrov
Reply | Threaded
Open this post in threaded view
|

Re: Ignite AWS library to support spark 3.0.1 and scala 2.12.12 version

Hi,

Spark 3.0 is not supported for Apache Ignite, nor in the GridGain
plugin. Supported Spark versions: 2.3 and 2.4.

BR,
Andrei

3/31/2021 9:49 PM, ChandanS пишет:

> Hi All,
>
> Can anyone please let me know which apache or grid-gain ignite library for
> AWS EC2 instance deployment will support AWS EMR spark application with
> spark-3.0.1 and scala-2.12.12 version to access the ignite cache launched in
> AWS EC2 instances from EMR spark job?
>
> Currently, I am using "gridgain-community-8.8.1" library, but it supports
> EMR spark job with spark-2.4.4 and scala-2.11.12. It's not working with my
> required spark-3.0.1 and scala-2.12.12 versions.
>
> Any help or suggestion will be highly appreciated.
>
>
> Thanks,
> Chandan
>
>
>
> --
> Sent from: http://apache-ignite-users.70518.x6.nabble.com/