Unable to find the ml.inference package

classic Classic list List threaded Threaded
2 messages Options
captcha captcha
Reply | Threaded
Open this post in threaded view
|

Unable to find the ml.inference package

Hi here,

I'm trying to use the ML inference API to do ML model predictions in Ignite.
I included the org.apache.ignite:ignite-ml dependency in my project. I'm
able to see most packages and methods in the dependency. However seems the
inference APIs
(https://github.com/apache/ignite/tree/master/modules/ml/src/main/java/org/apache/ignite/ml/inference)
are not there. The version I use is 2.7.6.






--
Sent from: http://apache-ignite-users.70518.x6.nabble.com/
Denis Mekhanikov Denis Mekhanikov
Reply | Threaded
Open this post in threaded view
|

Re: Unable to find the ml.inference package

This package hasn’t  been released yet.
It’s planned to be released in Apache Ignite 2.8. Here is the ticket under which this package was created: https://issues.apache.org/jira/browse/IGNITE-10234

Till then you can try using a nightly build: https://ignite.apache.org/download.cgi#nightly-builds
But note that nightly builds are much less stable than regular releases, so it’s not recommended to use them in production. They are for development only.

Denis
On 16 Oct 2019, 23:06 +0300, captcha <[hidden email]>, wrote:
Hi here,

I'm trying to use the ML inference API to do ML model predictions in Ignite.
I included the org.apache.ignite:ignite-ml dependency in my project. I'm
able to see most packages and methods in the dependency. However seems the
inference APIs
(https://github.com/apache/ignite/tree/master/modules/ml/src/main/java/org/apache/ignite/ml/inference)
are not there. The version I use is 2.7.6.






--
Sent from: http://apache-ignite-users.70518.x6.nabble.com/