Unable to find ignite artifacts

classic Classic list List threaded Threaded
5 messages Options
Kobe Kobe
Reply | Threaded
Open this post in threaded view
|

Unable to find ignite artifacts

I am unable to find the ignite hadoop2-integration and ignite-spring artifacts.
Could you pl let me know the ignite maven repo?

I also find that https://ignite.apache.org/download.html has a bunch of broken links
Pl help.

[CODE]
Failed to collect dependencies for [org.apache.ignite:ignite-core:jar:1.4.0 (compile), org.apache.ignite:ignite-spring:jar:1.4.0 (compile), org.apache.ignite:ignite-hadoop2-integration:jar:1.4.0 (compile)]:

[/CODE]

Thanx,

/Kobe
vkulichenko vkulichenko
Reply | Threaded
Open this post in threaded view
|

Re: Unable to find ignite artifacts

Hi Kobe,

All Ignite artifacts are in Maven Central, there is no designated repo. ignite-spring:1.4.0 [1] is there. ignite-hadoop2-integration module doesn't exist, but there is ignite-hadoop [2] (and this is the correct name).

It looks like you have some local configuration issue. I would try to completely delete the local repository (~/.m2/repository folder) and ~/.m2/settings.xml file. This will force Maven to build everything from scratch.

Hope this helps.

[1] http://search.maven.org/#search%7Cgav%7C1%7Cg%3A%22org.apache.ignite%22%20AND%20a%3A%22ignite-spring%22
[2] http://search.maven.org/#search%7Cga%7C1%7Cg%3A%22org.apache.ignite%22%20AND%20a%3A%22ignite-hadoop%22

-Val
vkulichenko vkulichenko
Reply | Threaded
Open this post in threaded view
|

Re: Unable to find ignite artifacts

In reply to this post by Kobe
Kobe wrote
I also find that https://ignite.apache.org/download.html has a bunch of broken links
BTW, what links are broken on the website?

-Val
Kobe Kobe
Reply | Threaded
Open this post in threaded view
|

Re: Unable to find ignite artifacts

vkulichenko wrote
Kobe wrote
I also find that https://ignite.apache.org/download.html has a bunch of broken links
BTW, what links are broken on the website?

-Val
Hi Vai -

Here:
   https://ignite.apache.org/[preferred]/[distdir]/1.4.0/apache-ignite-1.4.0-src.zip

because of the placeholder variables [preferred] and [distdir].

Same happens when I click on 1.3.0 release artifacts.

Also, could I expect ignite to run using the jar artifacts alone or if ignite core is to be downloaded and installed in ${IGNITE_HOME} ?

Thanks,

Kobe
Denis Magda Denis Magda
Reply | Threaded
Open this post in threaded view
|

Re: Unable to find ignite artifacts

Hi Kobe,

You should choose either http or ftp mirror from the combo box "Selected
mirror" below.

We will fix this issue on our side. Thanks for pointing out to this.

--
Denis

On 12/1/2015 2:35 AM, Kobe wrote:

> vkulichenko wrote
>> Kobe wrote
>>> I also find that https://ignite.apache.org/download.html has a bunch of
>>> broken links
>> BTW, what links are broken on the website?
>>
>> -Val
> Hi Vai -
>
> Here:
>    
> https://ignite.apache.org/[preferred]/[distdir]/1.4.0/apache-ignite-1.4.0-src.zip
>
> because of the placeholder variables [preferred] and [distdir].
>
> Same happens when I click on 1.3.0 release artifacts.
>
> Also, could I expect ignite to run using the jar artifacts alone or if
> ignite core is to be downloaded and installed in ${IGNITE_HOME} ?
>
> Thanks,
>
> Kobe
>
>
>
> --
> View this message in context: http://apache-ignite-users.70518.x6.nabble.com/Unable-to-find-ignite-artifacts-tp2097p2102.html
> Sent from the Apache Ignite Users mailing list archive at Nabble.com.