Setting up Ignite-1.3.0 with Eclipse

classic Classic list List threaded Threaded
4 messages Options
droehl droehl
Reply | Threaded
Open this post in threaded view
|

Setting up Ignite-1.3.0 with Eclipse

Hi,

New user here. I am trying to set up my eclipse environment (realize most of you use Idea) but am having a little trouble. It seems that you want the src dir to be "java" dir not the "src" dir. I have been trying to do that to no avail. Perhaps someone here has already experienced this and can clue me in on what I am doing wrong. Thanks in advance.
droehl droehl
Reply | Threaded
Open this post in threaded view
|

Re: Setting up Ignite-1.3.0 with Eclipse

Please disregard. I realize this is really sort of a Maven project in eclipse question anyways. In case anyone else runs into this sometimes you just need to restart eclipse after altering the Java src build path to java. Thanks.
Raul Kripalani Raul Kripalani
Reply | Threaded
Open this post in threaded view
|

Re: Setting up Ignite-1.3.0 with Eclipse

It's actually a good question. Not everybody uses IntelliJ. I started off with Eclipse, but then I moved to IntelliJ for this project.
Here are some of the issues I encountered with Eclipse and how I solved them. 

Needless to say, you should start off by importing Ignite as a Maven project into Eclipse. And make sure you're running on at least Eclipse Mars.

* Had issues with Maven plugins. I added an ignore rule for those and ran the build manually from my console.
* Added generated source file directories to the build path for those modules.
* Eclipse does not like package-info.java files in the same package within both the src/main/java and src/test/java directories. Had to add a build path exclusion rule to stop Eclipse from complaining (it was OK for Maven).

I planned on compiling these points in the Wiki, but then I switched to IntelliJ for this project to make life easier. The only reason I stick with Eclipse is because of its WSDL and XSD graphical IDE, really.

Regards,

Raúl Kripalani
Apache Camel PMC Member & Committer | Enterprise Architect, Open Source Integration specialist
http://blog.raulkr.net | twitter: @raulvk

On Thu, Aug 13, 2015 at 9:44 PM, droehl <[hidden email]> wrote:
Please disregard. I realize this is really sort of a Maven project in eclipse
question anyways. In case anyone else runs into this sometimes you just need
to restart eclipse after altering the Java src build path to java. Thanks.



--
View this message in context: http://apache-ignite-users.70518.x6.nabble.com/Setting-up-Ignite-1-3-0-with-Eclipse-tp951p958.html
Sent from the Apache Ignite Users mailing list archive at Nabble.com.

vkulichenko vkulichenko
Reply | Threaded
Open this post in threaded view
|

Re: Setting up Ignite-1.3.0 with Eclipse

BTW, there is a ticket for this: https://issues.apache.org/jira/browse/IGNITE-1187

I think it would be great if someone who already went through the setup process in Eclipse will pick it up.

-Val