Respective XML Configuration for @QueryTextField in ignite-default.xml

classic Classic list List threaded Threaded
2 messages Options
ram.gaurav.chhabra ram.gaurav.chhabra
Reply | Threaded
Open this post in threaded view
|

Respective XML Configuration for @QueryTextField in ignite-default.xml

Hello All,

Currently working on one module which is using Apache Ignite and all
configuration is driven through XML(ignite-default.xml).

Got one requirement where-in i need to implement full text search which can
be achieved by *@QueryTextField*

I have done this change and annotated respective field in domain object but
as my actual configuration is in XML for this domain object which is being
saved to cache, *@QueryTextField* this is not working and I am not getting
any result.

Just need help if anybody could please suggest respective XML configuration
for @QueryTextField so that it started working. I searched on internet but
not able to find relevant xml configuration.

Thanks



--
Sent from: http://apache-ignite-users.70518.x6.nabble.com/
ilya.kasnacheev ilya.kasnacheev
Reply | Threaded
Open this post in threaded view
|

Re: Respective XML Configuration for @QueryTextField in ignite-default.xml

Hello!

I think in your QueryEntity you need to declare an index of type QueryIndexType.FULLTEXT.

Regards,
--
Ilya Kasnacheev


вт, 23 июн. 2020 г. в 19:35, ram.gaurav.chhabra <[hidden email]>:
Hello All,

Currently working on one module which is using Apache Ignite and all
configuration is driven through XML(ignite-default.xml).

Got one requirement where-in i need to implement full text search which can
be achieved by *@QueryTextField*

I have done this change and annotated respective field in domain object but
as my actual configuration is in XML for this domain object which is being
saved to cache, *@QueryTextField* this is not working and I am not getting
any result.

Just need help if anybody could please suggest respective XML configuration
for @QueryTextField so that it started working. I searched on internet but
not able to find relevant xml configuration.

Thanks



--
Sent from: http://apache-ignite-users.70518.x6.nabble.com/