Required Spring jars for Configuration

classic Classic list List threaded Threaded
2 messages Options
Kamal Kamal
Reply | Threaded
Open this post in threaded view
|

Required Spring jars for Configuration

Hi all,

    I'm using Ignite Spring configuration files to configure the Ignite and cache instances.

The `Ignite-Spring` folder consists of many jars. In my application, I'm not using spring framework. How to find only the required jars which loads the configuration files?

a. commons-logging-1.1.1.jar
b. ignite-spring-1.6.0.jar
c. spring-aop-4.1.0.RELEASE.jar
d. spring-beans-4.1.0.RELEASE.jar
e. spring-context-4.1.0.RELEASE.jar
f. spring-core-4.1.0.RELEASE.jar
g. spring-expression-4.1.0.RELEASE.jar
h. spring-jdbc-4.1.0.RELEASE.jar
i. spring-tx-4.1.0.RELEASE.jar


Regards,
Kamal C

vdpyatkov vdpyatkov
Reply | Threaded
Open this post in threaded view
|

Re: Required Spring jars for Configuration

Hello Kamal,
I think you can rule out a, g, h and i. 
But I could be wrong, it should be checked. Simply remove jars from the assembly and try to run.