Persistence store data not getting distributed across files on different machine in cluster

classic Classic list List threaded Threaded
4 messages Options
aMark aMark
Reply | Threaded
Open this post in threaded view
|

Persistence store data not getting distributed across files on different machine in cluster

Hi,

We are using Ignite as persistent store in Partitioned Mode having 6 cluster
node running, each node is running on different machine.
We started with Ignite-2.1 then upgrade to Ignite-2.3 in Feb-18. Recently we
have upgraded from Ignite 2.3 to Ignite 2.5, but we are seeing one issue
related to persistent store.
Earlier persistent store directory used to be
0_0_0_0_0_0_0_1_lo_10_32_15_46_10_32_15_30_10_32_15_30_127_0_0_1_47500 but
looks like after upgrade new folder has been created with format :
node00-<uuid>.

But now when cache is added to ignite ealier cached data were getting
distributed across various nodes but after upgrade data is going to only one
node (say node 1). I can see the cache in other nodes (node 2 to node 6) but
bin files does not contain cache data on other nodes (node 2 to node 6) and
contain data only on node 1.

This has created an issue of high disk space use on node 1 while sufficient
disk is available on other nodes.

Any help is much appreciated.

Thanks





--
Sent from: http://apache-ignite-users.70518.x6.nabble.com/
Maxim.Pudov Maxim.Pudov
Reply | Threaded
Open this post in threaded view
|

Re: Persistence store data not getting distributed across files on different machine in cluster

Hi.
It might be the case of improperly activated cluster. You can check which
nodes are in the base topology by using a command
./control.sh --baseline
Here https://apacheignite.readme.io/docs/baseline-topology you can read more
about it.
Hope it will help.



--
Sent from: http://apache-ignite-users.70518.x6.nabble.com/
aMark aMark
Reply | Threaded
Open this post in threaded view
|

Re: Persistence store data not getting distributed across files on different machine in cluster

Thanks Maxim.

I have CLEARED various directories Work/WalStore/IgnitePersistentStore and
WalArchive on all the nodes and starting the cluster in clean state.  

After this I can see that nodes have been created using node00_uuid format.

BUT cache data is still not getting partitioned across various nodes. Though
cache nodes is configured for CacheMode.PARTITIONED with backup as 1.

Please let me know if more information is required.





--
Sent from: http://apache-ignite-users.70518.x6.nabble.com/
Maxim.Pudov Maxim.Pudov
Reply | Threaded
Open this post in threaded view
|

Re: Persistence store data not getting distributed across files on different machine in cluster

Looks like you baseline topology (nodes used for persistence) contains only 1
node. Have you tried adding other nodes to the baseline topology? Please
follow this guide
https://apacheignite.readme.io/docs/baseline-topology#section--add-nodes-to-the-topology
to do so.



--
Sent from: http://apache-ignite-users.70518.x6.nabble.com/