Partitioned cache didn't distributed for all the server nodes

classic Classic list List threaded Threaded
3 messages Options
raja24 raja24
Reply | Threaded
Open this post in threaded view
|

Partitioned cache didn't distributed for all the server nodes

Hi,

I haven below configuration and partitioned cache didn't distributed for all
the server nodes.

<bean id="expiryPolicy"
class="javax.cache.configuration.FactoryBuilder$SingletonFactory">
        <constructor-arg>
            <bean class="javax.cache.expiry.CreatedExpiryPolicy">
                <constructor-arg>
                    <bean class="javax.cache.expiry.Duration">
                        <constructor-arg
type="java.util.concurrent.TimeUnit" value="MINUTES"/>
                        <constructor-arg value="1"/>
                    </bean>
                </constructor-arg>
            </bean>
        </constructor-arg>
    </bean>
       
        <bean class="org.apache.ignite.configuration.CacheConfiguration">
        <property name="name" value="service-work-cache"/>
        <property name="cacheMode" value="PARTITIONED"/>
        <property name="atomicityMode" value="ATOMIC"/>
                <property name="expiryPolicyFactory">
                        <bean parent="expiryPolicy"/>
                                       
                </property>
    </bean>


Thanks,
Raja



--
Sent from: http://apache-ignite-users.70518.x6.nabble.com/
stephendarlington stephendarlington
Reply | Threaded
Open this post in threaded view
|

Re: Partitioned cache didn't distributed for all the server nodes

How many nodes in your cluster? How many keys in your dataset?

Regards,
Stephen

> On 22 Jul 2019, at 16:16, raja24 <[hidden email]> wrote:
>
> Hi,
>
> I haven below configuration and partitioned cache didn't distributed for all
> the server nodes.
>
> <bean id="expiryPolicy"
> class="javax.cache.configuration.FactoryBuilder$SingletonFactory">
>        <constructor-arg>
>            <bean class="javax.cache.expiry.CreatedExpiryPolicy">
>                <constructor-arg>
>                    <bean class="javax.cache.expiry.Duration">
>                        <constructor-arg
> type="java.util.concurrent.TimeUnit" value="MINUTES"/>
>                        <constructor-arg value="1"/>
>                    </bean>
>                </constructor-arg>
>            </bean>
>        </constructor-arg>
>    </bean>
>
> <bean class="org.apache.ignite.configuration.CacheConfiguration">
>        <property name="name" value="service-work-cache"/>
>        <property name="cacheMode" value="PARTITIONED"/>
>        <property name="atomicityMode" value="ATOMIC"/>
> <property name="expiryPolicyFactory">
> <bean parent="expiryPolicy"/>
>
> </property>
>    </bean>
>
>
> Thanks,
> Raja
>
>
>
> --
> Sent from: http://apache-ignite-users.70518.x6.nabble.com/


raja24 raja24
Reply | Threaded
Open this post in threaded view
|

Re: Partitioned cache didn't distributed for all the server nodes

Stephen,

Thanks for your quick response.
It's my bad and I have added below entry and resolved the issue.

        <property name="backups" value="1"/>



Thanks,
Raja.



--
Sent from: http://apache-ignite-users.70518.x6.nabble.com/