NullPointer Exception while starting new client cache node

classic Classic list List threaded Threaded
2 messages Options
Pawan Jangid Pawan Jangid
Reply | Threaded
Open this post in threaded view
|

NullPointer Exception while starting new client cache node

Hi,

I have multiple thick Clients which are getting started as an embedded mode on a weblogic server and a standalone server node is exists inside a docker container. Both the server and client nodes are on the same machine.


I'm getting NullPointerException randomly while starting a new client and after the exception server node goes down and all the clients gets stuck as well as all the request coming on weblogic server. For reference logs has been attached.


ignite : 2.7.5

weblogic : 14.1.1.0.0


Please help me to fix this issue.


Regards,

Pawan Jangid



ignite-b180492a.0.log (8M) Download Attachment
ilya.kasnacheev ilya.kasnacheev
Reply | Threaded
Open this post in threaded view
|

Re: NullPointer Exception while starting new client cache node

Hello!

I believe this question is answered on SO:

I have also filed a ticket about this issue: https://issues.apache.org/jira/browse/IGNITE-14466

Regards,
--
Ilya Kasnacheev


ср, 31 мар. 2021 г. в 10:33, Pawan Jangid <[hidden email]>:
Hi,

I have multiple thick Clients which are getting started as an embedded mode on a weblogic server and a standalone server node is exists inside a docker container. Both the server and client nodes are on the same machine.


I'm getting NullPointerException randomly while starting a new client and after the exception server node goes down and all the clients gets stuck as well as all the request coming on weblogic server. For reference logs has been attached.


ignite : 2.7.5

weblogic : 14.1.1.0.0


Please help me to fix this issue.


Regards,

Pawan Jangid