Node failing with weird errors

classic Classic list List threaded Threaded
4 messages Options
Ognen Duzlevski Ognen Duzlevski
Reply | Threaded
Open this post in threaded view
|

Node failing with weird errors

Can anyone shed any light on this? Thanks!

[22:09:32,130][INFO][disco-event-worker-#46%null%][GridDiscoveryManager] Added new node to topology: TcpDiscoveryNode [id=892b41bd-1143-4fc4-a10f-f7fd9a4fd4b0, addrs=[10.10.212.125, 127.0.0.1], sockAddrs=[dev-ognen03.vpc/10.10.212.125:47500, /10.10.212.125:47500, /127.0.0.1:47500], discPort=47500, order=579, intOrder=293, loc=false, ver=1.0.0#20150328-sha1:5fc2cd05, isClient=false]
[22:09:32,131][INFO][disco-event-worker-#46%null%][GridDiscoveryManager] Topology snapshot [ver=580, nodes=7, CPUs=40, heap=110.0GB]
[22:09:32,131][WARNING][disco-event-worker-#46%null%][GridDiscoveryManager] Node FAILED: TcpDiscoveryNode [id=892b41bd-1143-4fc4-a10f-f7fd9a4fd4b0, addrs=[10.10.212.125, 127.0.0.1], sockAddrs=[dev-ognen03.vpc/10.10.212.125:47500, /10.10.212.125:47500, /127.0.0.1:47500], discPort=47500, order=579, intOrder=293, loc=false, ver=1.0.0#20150328-sha1:5fc2cd05, isClient=false]
[22:09:32,131][INFO][disco-event-worker-#46%null%][GridDiscoveryManager] Topology snapshot [ver=580, nodes=6, CPUs=32, heap=88.0GB]
[22:09:32,132][SEVERE][disco-event-worker-#46%null%][GridEventStorageManager] Unexpected exception in listener notification for event: DiscoveryEvent [evtNode=TcpDiscoveryNode [id=892b41bd-1143-4fc4-a10f-f7fd9a4fd4b0, addrs=[10.10.212.125, 127.0.0.1], sockAddrs=[dev-ognen03.vpc/10.10.212.125:47500, /10.10.212.125:47500, /127.0.0.1:47500], discPort=47500, order=579, intOrder=293, loc=false, ver=1.0.0#20150328-sha1:5fc2cd05, isClient=false], topVer=580, nodeId8=bd33def3, msg=Node failed: TcpDiscoveryNode [id=892b41bd-1143-4fc4-a10f-f7fd9a4fd4b0, addrs=[10.10.212.125, 127.0.0.1], sockAddrs=[dev-ognen03.vpc/10.10.212.125:47500, /10.10.212.125:47500, /127.0.0.1:47500], discPort=47500, order=579, intOrder=293, loc=false, ver=1.0.0#20150328-sha1:5fc2cd05, isClient=false], type=NODE_FAILED, tstamp=1431400172125]
java.lang.NullPointerException
        at org.apache.ignite.internal.processors.cache.distributed.dht.preloader.GridDhtPartitionsExchangeFuture$4.apply(GridDhtPartitionsExchangeFuture.java:1064)
        at org.apache.ignite.internal.processors.cache.distributed.dht.preloader.GridDhtPartitionsExchangeFuture$4.apply(GridDhtPartitionsExchangeFuture.java:1046)
        at org.apache.ignite.internal.util.future.GridFutureAdapter.notifyListener(GridFutureAdapter.java:227)
        at org.apache.ignite.internal.util.future.GridFutureAdapter.listen(GridFutureAdapter.java:190)
        at org.apache.ignite.internal.processors.cache.distributed.dht.preloader.GridDhtPartitionsExchangeFuture.onNodeLeft(GridDhtPartitionsExchangeFuture.java:1046)
        at org.apache.ignite.internal.processors.cache.GridCachePartitionExchangeManager$1.onEvent(GridCachePartitionExchangeManager.java:128)
        at org.apache.ignite.internal.managers.eventstorage.GridEventStorageManager.notifyListeners(GridEventStorageManager.java:739)
        at org.apache.ignite.internal.managers.eventstorage.GridEventStorageManager.notifyListeners(GridEventStorageManager.java:724)
        at org.apache.ignite.internal.managers.eventstorage.GridEventStorageManager.record(GridEventStorageManager.java:272)
        at org.apache.ignite.internal.managers.discovery.GridDiscoveryManager$DiscoveryWorker.recordEvent(GridDiscoveryManager.java:1510)
        at org.apache.ignite.internal.managers.discovery.GridDiscoveryManager$DiscoveryWorker.body0(GridDiscoveryManager.java:1697)
        at org.apache.ignite.internal.managers.discovery.GridDiscoveryManager$DiscoveryWorker.body(GridDiscoveryManager.java:1549)
        at org.apache.ignite.internal.util.worker.GridWorker.run(GridWorker.java:107)
        at java.lang.Thread.run(Thread.java:745)
vkulichenko vkulichenko
Reply | Threaded
Open this post in threaded view
|

Re: Node failing with weird errors

Ognen,

I believe this is already fixed. Next release is on the vote now and will include the fix.
dsetrakyan dsetrakyan
Reply | Threaded
Open this post in threaded view
|

Re: Node failing with weird errors

To my knowledge this is already available in GridGain Community Edition, 1.0.4 and will become part of official Apache Ignite 1.1 release in a week or two, once it passes voting.

D.
Ognen Duzlevski Ognen Duzlevski
Reply | Threaded
Open this post in threaded view
|

Re: Node failing with weird errors

Ok - excellent - thanks!

On Tue, May 12, 2015 at 1:49 PM, dsetrakyan <[hidden email]> wrote:
To my knowledge this is already available in GridGain Community Edition,
1.0.4 and will become part of official Apache Ignite 1.1 release in a week
or two, once it passes voting.

D.



--
View this message in context: http://apache-ignite-users.70518.x6.nabble.com/Node-failing-with-weird-errors-tp301p304.html
Sent from the Apache Ignite Users mailing list archive at Nabble.com.