No ignitevisorcmd.sh in Ignite 2.8

classic Classic list List threaded Threaded
12 messages Options
joaogoncalves joaogoncalves
Reply | Threaded
Open this post in threaded view
|

No ignitevisorcmd.sh in Ignite 2.8

Hi
Recently started working with Ignite on version 2.8.0

Can't find ignitevisorcmd.sh, was it removed? According to
https://apacheignite-tools.readme.io/docs/command-line-interface
<https://apacheignite-tools.readme.io/docs/command-line-interface>   it
should be under IGNITE_HOME/bin

I found IGNITE_HOME/bin/include/visorcmd/ignite-visor-console-2.8.0.jar and
tried to run it but got:
"no main manifest attribute, in ignite-visor-console-2.8.0.jar"

Clearly it must run somehow but I can't find any documentation on how to do
it.



--
Sent from: http://apache-ignite-users.70518.x6.nabble.com/
stephendarlington stephendarlington
Reply | Threaded
Open this post in threaded view
|

Re: No ignitevisorcmd.sh in Ignite 2.8

Where did you download it from? Did you download the binary or source version? It’s there in my download:

~ stephen.darlington$ cd $IGNITE_HOME
-ignite-2.8.0-bin stephen.darlington$ ls bin/*sh
bin/control.sh bin/igniterouter.sh bin/sqlline.sh
bin/ignite.sh bin/ignitevisorcmd.sh
apache-ignite-2.8.0-bin stephen.darlington$ 

Regards,
Stephen

On 20 Mar 2020, at 19:19, joaogoncalves <[hidden email]> wrote:

Hi
Recently started working with Ignite on version 2.8.0

Can't find ignitevisorcmd.sh, was it removed? According to
https://apacheignite-tools.readme.io/docs/command-line-interface
<https://apacheignite-tools.readme.io/docs/command-line-interface>   it
should be under IGNITE_HOME/bin

I found IGNITE_HOME/bin/include/visorcmd/ignite-visor-console-2.8.0.jar and
tried to run it but got:
"no main manifest attribute, in ignite-visor-console-2.8.0.jar"

Clearly it must run somehow but I can't find any documentation on how to do
it.



--
Sent from: http://apache-ignite-users.70518.x6.nabble.com/


joaogoncalves joaogoncalves
Reply | Threaded
Open this post in threaded view
|

Re: No ignitevisorcmd.sh in Ignite 2.8

Thanks for the quick reply


Which one should I use?


Stephen Darlington <[hidden email]> escreveu no dia sexta, 20/03/2020 à(s) 20:30:
Where did you download it from? Did you download the binary or source version? It’s there in my download:

~ stephen.darlington$ cd $IGNITE_HOME
-ignite-2.8.0-bin stephen.darlington$ ls bin/*sh
bin/control.sh bin/igniterouter.sh bin/sqlline.sh
bin/ignite.sh bin/ignitevisorcmd.sh
apache-ignite-2.8.0-bin stephen.darlington$ 

Regards,
Stephen

On 20 Mar 2020, at 19:19, joaogoncalves <[hidden email]> wrote:

Hi
Recently started working with Ignite on version 2.8.0

Can't find ignitevisorcmd.sh, was it removed? According to
https://apacheignite-tools.readme.io/docs/command-line-interface
<https://apacheignite-tools.readme.io/docs/command-line-interface>   it
should be under IGNITE_HOME/bin

I found IGNITE_HOME/bin/include/visorcmd/ignite-visor-console-2.8.0.jar and
tried to run it but got:
"no main manifest attribute, in ignite-visor-console-2.8.0.jar"

Clearly it must run somehow but I can't find any documentation on how to do
it.



--
Sent from: http://apache-ignite-users.70518.x6.nabble.com/


stephendarlington stephendarlington
Reply | Threaded
Open this post in threaded view
|

Re: No ignitevisorcmd.sh in Ignite 2.8

Ah, apparently it doesn’t work when installed from a package. It’s in the doc directory somewhere. See here for a discussion from when 2.7.5 was current: http://apache-ignite-users.70518.x6.nabble.com/2-7-5-IGNITE-HOME-bin-ignitevisorcmd-sh-is-absent-td28629.html

Regards,
Stephen

On 20 Mar 2020, at 20:46, João Gonçalves <[hidden email]> wrote:

Thanks for the quick reply


Which one should I use?


Stephen Darlington <[hidden email]> escreveu no dia sexta, 20/03/2020 à(s) 20:30:
Where did you download it from? Did you download the binary or source version? It’s there in my download:

~ stephen.darlington$ cd $IGNITE_HOME
-ignite-2.8.0-bin stephen.darlington$ ls bin/*sh
bin/control.sh bin/igniterouter.sh bin/sqlline.sh
bin/ignite.sh bin/ignitevisorcmd.sh
apache-ignite-2.8.0-bin stephen.darlington$ 

Regards,
Stephen

On 20 Mar 2020, at 19:19, joaogoncalves <[hidden email]> wrote:

Hi
Recently started working with Ignite on version 2.8.0

Can't find ignitevisorcmd.sh, was it removed? According to
https://apacheignite-tools.readme.io/docs/command-line-interface
<https://apacheignite-tools.readme.io/docs/command-line-interface>   it
should be under IGNITE_HOME/bin

I found IGNITE_HOME/bin/include/visorcmd/ignite-visor-console-2.8.0.jar and
tried to run it but got:
"no main manifest attribute, in ignite-visor-console-2.8.0.jar"

Clearly it must run somehow but I can't find any documentation on how to do
it.



--
Sent from: http://apache-ignite-users.70518.x6.nabble.com/




Petr Ivanov Petr Ivanov
Reply | Threaded
Open this post in threaded view
|

Re: No ignitevisorcmd.sh in Ignite 2.8

ignitevisorcmd was moved to docs by design, due to lack of time to configure package to install it correctly into system as ignite.sh is being installed (PATH, alternatives, etc.)


On 20 Mar 2020, at 23:55, Stephen Darlington <[hidden email]> wrote:

Ah, apparently it doesn’t work when installed from a package. It’s in the doc directory somewhere. See here for a discussion from when 2.7.5 was current: http://apache-ignite-users.70518.x6.nabble.com/2-7-5-IGNITE-HOME-bin-ignitevisorcmd-sh-is-absent-td28629.html

Regards,
Stephen

On 20 Mar 2020, at 20:46, João Gonçalves <[hidden email]> wrote:

Thanks for the quick reply


Which one should I use?


Stephen Darlington <[hidden email]> escreveu no dia sexta, 20/03/2020 à(s) 20:30:
Where did you download it from? Did you download the binary or source version? It’s there in my download:

~ stephen.darlington$ cd $IGNITE_HOME
-ignite-2.8.0-bin stephen.darlington$ ls bin/*sh
bin/control.sh bin/igniterouter.sh bin/sqlline.sh
bin/ignite.sh bin/ignitevisorcmd.sh
apache-ignite-2.8.0-bin stephen.darlington$ 

Regards,
Stephen

On 20 Mar 2020, at 19:19, joaogoncalves <[hidden email]> wrote:

Hi
Recently started working with Ignite on version 2.8.0

Can't find ignitevisorcmd.sh, was it removed? According to
https://apacheignite-tools.readme.io/docs/command-line-interface
<https://apacheignite-tools.readme.io/docs/command-line-interface>   it
should be under IGNITE_HOME/bin

I found IGNITE_HOME/bin/include/visorcmd/ignite-visor-console-2.8.0.jar and
tried to run it but got:
"no main manifest attribute, in ignite-visor-console-2.8.0.jar"

Clearly it must run somehow but I can't find any documentation on how to do
it.



--
Sent from: http://apache-ignite-users.70518.x6.nabble.com/





joaogoncalves joaogoncalves
Reply | Threaded
Open this post in threaded view
|

Re: No ignitevisorcmd.sh in Ignite 2.8

Hi again

I now downloaded the binary and started ignite in a screen.

I started ignitevisorcmd.sh but can't connect to my running node with the
'open' command.

I can connect to ignite with sqlline and inspect tables.

Any clues?



--
Sent from: http://apache-ignite-users.70518.x6.nabble.com/
stephendarlington stephendarlington
Reply | Threaded
Open this post in threaded view
|

Re: No ignitevisorcmd.sh in Ignite 2.8

Are you getting any error messages? Are you giving it the same configuration file as you give the server nodes? It works when I try it with the default options.

> On 23 Mar 2020, at 12:03, joaogoncalves <[hidden email]> wrote:
>
> Hi again
>
> I now downloaded the binary and started ignite in a screen.
>
> I started ignitevisorcmd.sh but can't connect to my running node with the
> 'open' command.
>
> I can connect to ignite with sqlline and inspect tables.
>
> Any clues?
>
>
>
> --
> Sent from: http://apache-ignite-users.70518.x6.nabble.com/


joaogoncalves joaogoncalves
Reply | Threaded
Open this post in threaded view
|

Re: No ignitevisorcmd.sh in Ignite 2.8

I am starting ignite with my custom config file like:

./bin/ignite.sh config.xml

Below is my config file:

<beans xmlns="http://www.springframework.org/schema/beans"
  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
  xsi:schemaLocation="
       http://www.springframework.org/schema/beans
       http://www.springframework.org/schema/beans/spring-beans.xsd">
 
  <bean id="grid.cfg"
class="org.apache.ignite.configuration.IgniteConfiguration">

    <property name="cacheConfiguration">
      <list>
       
        <bean class="org.apache.ignite.configuration.CacheConfiguration">
          <property name="name" value="mytestcache*"/>
          <property name="sqlEscapeAll" value="true"/>
          <property name="dataRegionName" value="mycustom1GB_Region"/>
         
         
        </bean>
      </list>
    </property>

   
    <property name="dataStorageConfiguration">
      <bean
class="org.apache.ignite.configuration.DataStorageConfiguration">
        <property name="dataRegionConfigurations">
          <list>
           
            <bean
class="org.apache.ignite.configuration.DataRegionConfiguration">
             
              <property name="name" value="mycustom1GB_Region"/>

             
              <property name="initialSize" value="#{500L * 1024 * 1024}"/>

             
              <property name="maxSize" value="#{1024L * 1024 * 1024}"/>

             
             
            </bean>
          </list>
        </property>
      </bean>
    </property>

    <property name="discoverySpi">
      <bean class="org.apache.ignite.spi.discovery.tcp.TcpDiscoverySpi">
        <property name="ipFinder">
          <bean
class="org.apache.ignite.spi.discovery.tcp.ipfinder.vm.TcpDiscoveryVmIpFinder">
            <property name="addresses">
              <list>
               
               

               
                <value>127.0.0.1:47500..47509</value>
              </list>
            </property>
          </bean>
        </property>
      </bean>
    </property>

  </bean>
</beans>


I then run ignitevisorcmd.sh, execute the 'open' command and select the same
config.xml.
The status remains the same:

+-------------------------------------+
| Status               | Disconnected |
| Ignite instance name | <n/a>        |
| Config path          | <n/a>        |
| Uptime               | <n/a>        |
+-------------------------------------+

I want to use ignitevisor so i can inspect a cache configuration that i
suspect is not being loaded. If you noticed in my config, i have defined a
cache template with the following setting:

<property name="sqlEscapeAll" value="true"/>

This was supposed to make ignite case sensitive when creating tables, so
that i get my table names and field names in lowercase.

This is not directly related to ignitevisor and maybe i should move it to
another post?

Thanks for your help so far.





--
Sent from: http://apache-ignite-users.70518.x6.nabble.com/
stephendarlington stephendarlington
Reply | Threaded
Open this post in threaded view
|

Re: No ignitevisorcmd.sh in Ignite 2.8

Are you starting ignitevisor on the same machine as your server? There’s no problem with your discovery configuration. I can use your configuration to start a server node and Visor on my laptop.

> On 23 Mar 2020, at 15:38, joaogoncalves <[hidden email]> wrote:
>
> I am starting ignite with my custom config file like:
>
> ./bin/ignite.sh config.xml
>
> Below is my config file:
>
> <beans xmlns="http://www.springframework.org/schema/beans"
>  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
>  xsi:schemaLocation="
>       http://www.springframework.org/schema/beans
>       http://www.springframework.org/schema/beans/spring-beans.xsd">
>
>  <bean id="grid.cfg"
> class="org.apache.ignite.configuration.IgniteConfiguration">
>
>    <property name="cacheConfiguration">
>      <list>
>
>        <bean class="org.apache.ignite.configuration.CacheConfiguration">
>          <property name="name" value="mytestcache*"/>
>          <property name="sqlEscapeAll" value="true"/>
>          <property name="dataRegionName" value="mycustom1GB_Region"/>
>
>
>        </bean>
>      </list>
>    </property>
>
>
>    <property name="dataStorageConfiguration">
>      <bean
> class="org.apache.ignite.configuration.DataStorageConfiguration">
>        <property name="dataRegionConfigurations">
>          <list>
>
>            <bean
> class="org.apache.ignite.configuration.DataRegionConfiguration">
>
>              <property name="name" value="mycustom1GB_Region"/>
>
>
>              <property name="initialSize" value="#{500L * 1024 * 1024}"/>
>
>
>              <property name="maxSize" value="#{1024L * 1024 * 1024}"/>
>
>
>
>            </bean>
>          </list>
>        </property>
>      </bean>
>    </property>
>
>    <property name="discoverySpi">
>      <bean class="org.apache.ignite.spi.discovery.tcp.TcpDiscoverySpi">
>        <property name="ipFinder">
>          <bean
> class="org.apache.ignite.spi.discovery.tcp.ipfinder.vm.TcpDiscoveryVmIpFinder">
>            <property name="addresses">
>              <list>
>
>
>
>
>                <value>127.0.0.1:47500..47509</value>
>              </list>
>            </property>
>          </bean>
>        </property>
>      </bean>
>    </property>
>
>  </bean>
> </beans>
>
>
> I then run ignitevisorcmd.sh, execute the 'open' command and select the same
> config.xml.
> The status remains the same:
>
> +-------------------------------------+
> | Status               | Disconnected |
> | Ignite instance name | <n/a>        |
> | Config path          | <n/a>        |
> | Uptime               | <n/a>        |
> +-------------------------------------+
>
> I want to use ignitevisor so i can inspect a cache configuration that i
> suspect is not being loaded. If you noticed in my config, i have defined a
> cache template with the following setting:
>
> <property name="sqlEscapeAll" value="true"/>
>
> This was supposed to make ignite case sensitive when creating tables, so
> that i get my table names and field names in lowercase.
>
> This is not directly related to ignitevisor and maybe i should move it to
> another post?
>
> Thanks for your help so far.
>
>
>
>
>
> --
> Sent from: http://apache-ignite-users.70518.x6.nabble.com/


joaogoncalves joaogoncalves
Reply | Threaded
Open this post in threaded view
|

Re: No ignitevisorcmd.sh in Ignite 2.8

Yes, im running ignitevisor on the same machine.

I've been testing, trying to start ignite with example config files, and I'm
not able to connect to ignite with any of them. It starts up correctly, but
I can't connect.

I get no errors, except on one of them:

Caused by: class org.apache.ignite.IgniteCheckedException: Failed to find
configuration in: file:/opt/ignite/examples/config/example-default.xml

This is the content of that file:


<?xml version="1.0" encoding="UTF-8"?>




<beans xmlns="http://www.springframework.org/schema/beans"
       xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
       xmlns:util="http://www.springframework.org/schema/util"
       xsi:schemaLocation="
        http://www.springframework.org/schema/beans
        http://www.springframework.org/schema/beans/spring-beans.xsd
        http://www.springframework.org/schema/util
        http://www.springframework.org/schema/util/spring-util.xsd">
    <bean abstract="true" id="ignite.cfg"
class="org.apache.ignite.configuration.IgniteConfiguration">
       
        <property name="peerClassLoadingEnabled" value="true"/>

       
        <property name="includeEventTypes">
            <list>
               
                <util:constant
static-field="org.apache.ignite.events.EventType.EVT_TASK_STARTED"/>
                <util:constant
static-field="org.apache.ignite.events.EventType.EVT_TASK_FINISHED"/>
                <util:constant
static-field="org.apache.ignite.events.EventType.EVT_TASK_FAILED"/>
                <util:constant
static-field="org.apache.ignite.events.EventType.EVT_TASK_TIMEDOUT"/>
                <util:constant
static-field="org.apache.ignite.events.EventType.EVT_TASK_SESSION_ATTR_SET"/>
                <util:constant
static-field="org.apache.ignite.events.EventType.EVT_TASK_REDUCED"/>

               
                <util:constant
static-field="org.apache.ignite.events.EventType.EVT_CACHE_OBJECT_PUT"/>
                <util:constant
static-field="org.apache.ignite.events.EventType.EVT_CACHE_OBJECT_READ"/>
                <util:constant
static-field="org.apache.ignite.events.EventType.EVT_CACHE_OBJECT_REMOVED"/>
            </list>
        </property>

       
        <property name="discoverySpi">
            <bean
class="org.apache.ignite.spi.discovery.tcp.TcpDiscoverySpi">
                <property name="ipFinder">
                   
                   
                   
                    <bean
class="org.apache.ignite.spi.discovery.tcp.ipfinder.multicast.TcpDiscoveryMulticastIpFinder">
                        <property name="addresses">
                            <list>
                               
                                <value>127.0.0.1:47500..47509</value>
                            </list>
                        </property>
                    </bean>
                </property>
            </bean>
        </property>
    </bean>
</beans>


I assume this is some configuration error within the file itself.

I've given full read/write permissions to the whole IGNITE_HOME and still
nothing.

Are there any other requisites to using ignitevisor that aren't specified in
the docs?
Is there any other way to inspect existing cache configurations?



 



--
Sent from: http://apache-ignite-users.70518.x6.nabble.com/
joaogoncalves joaogoncalves
Reply | Threaded
Open this post in threaded view
|

Re: No ignitevisorcmd.sh in Ignite 2.8

ilya.kasnacheev ilya.kasnacheev
Reply | Threaded
Open this post in threaded view
|

Re: No ignitevisorcmd.sh in Ignite 2.8

Hello!

We hope to ship a fix for it in 2.8.1: https://issues.apache.org/jira/browse/IGNITE-12757

Until then, you can apply recommendation from the linked thread.

Regards,
--
Ilya Kasnacheev


вт, 24 мар. 2020 г. в 14:10, joaogoncalves <[hidden email]>:
Hi again

It happened to be the same as  Thank you for your help
<http://apache-ignite-users.70518.x6.nabble.com/Unable-to-connect-to-Ignite-Visor-Console-in-Ignite-2-8-0-td31628.html>



--
Sent from: http://apache-ignite-users.70518.x6.nabble.com/