Ignite-hibernate latest version is not available in maven central

classic Classic list List threaded Threaded
4 messages Options
dnavre dnavre
Reply | Threaded
Open this post in threaded view
|

Ignite-hibernate latest version is not available in maven central

This post was updated on .
The latest stable version of ignite-hibernate available in maven central is 1.0.0
Bellow is the full list of available ignite-hibernate versions

1.2.0-incubating
1.1.0-incubating
1.0.0
1.0.0-RC3
1.0.0-RC1

As I understand ignite-hibernate is heavily advertised on the official website as something that should work and lacking it's latest version in the maven repo seems wrong to me.
vkulichenko vkulichenko
Reply | Threaded
Open this post in threaded view
|

Re: Ignite-hibernate latest version is not available in maven central

Hibernate is LGPL-licensed, so we stopped deploying there. To get artifacts that have LGPL dependencies, you need to build them from the source [1] and deploy in your local repo.

[1] http://ignite.apache.org/download.cgi#build-source

-Val
Anton Vinogradov Anton Vinogradov
Reply | Threaded
Open this post in threaded view
|

Re: Ignite-hibernate latest version is not available in maven central

Hi, 

You can use non-apache mvn repositories contain full list of Apache Ignite artifacts.
For example you can add dependency to this one:
We just uploaded release tags 1.5.0-final and 1.6.0 without modifications.

Please note that these jars are NOT official Apache Ignite jars

On Mon, May 30, 2016 at 12:36 PM, vkulichenko <[hidden email]> wrote:
Hibernate is LGPL-licensed, so we stopped deploying there. To get artifacts
that have LGPL dependencies, you need to build them from the source [1] and
deploy in your local repo.

[1] http://ignite.apache.org/download.cgi#build-source

-Val



--
View this message in context: http://apache-ignite-users.70518.x6.nabble.com/Ignite-hibernate-latest-version-is-not-available-in-maven-central-tp5288p5304.html
Sent from the Apache Ignite Users mailing list archive at Nabble.com.

dnavre dnavre
Reply | Threaded
Open this post in threaded view
|

Re: Ignite-hibernate latest version is not available in maven central

Thank a lot Anton, That was helpful. Though I've already compiled ignite-hibernate and have it installed in our local nexus.

I still don't get why those libraries being LGPL is an issue when publishing a jar to maven central. Your library(jar) doesn't contain source code from the lib that you have a dependency on. You're not distributing it or anything.

IMO you can compare it to writing a procedure in PL/SQL and open-sourcing it. You can do that, but PL/SQL is a proprietary technology which only works on Oracle DBs. 

On Thu, Jun 2, 2016 at 4:35 PM, Anton Vinogradov [via Apache Ignite Users] <[hidden email]> wrote:
Hi, 

You can use non-apache mvn repositories contain full list of Apache Ignite artifacts.
For example you can add dependency to this one:
We just uploaded release tags 1.5.0-final and 1.6.0 without modifications.

Please note that these jars are NOT official Apache Ignite jars

On Mon, May 30, 2016 at 12:36 PM, vkulichenko <[hidden email]> wrote:
Hibernate is LGPL-licensed, so we stopped deploying there. To get artifacts
that have LGPL dependencies, you need to build them from the source [1] and
deploy in your local repo.

[1] http://ignite.apache.org/download.cgi#build-source

-Val



--
View this message in context: http://apache-ignite-users.70518.x6.nabble.com/Ignite-hibernate-latest-version-is-not-available-in-maven-central-tp5288p5304.html
Sent from the Apache Ignite Users mailing list archive at Nabble.com.




To unsubscribe from Ignite-hibernate latest version is not available in maven central, click here.
NAML