Ignite Client crashes JVM while Connecting to cluster

classic Classic list List threaded Threaded
2 messages Options
PunxsutawneyPhil3 PunxsutawneyPhil3
Reply | Threaded
Open this post in threaded view
|

Ignite Client crashes JVM while Connecting to cluster

I recently changed from running Ignite with Multicast IP Finder to using
Static IP Finder to make district sets of clusters per machine.

Prior to this change I was able to establish a connection between the client
and the Ignite server. However, after specifying the Static IP finder in the
configuration of the server and the client, when I attempt to connect to the
server a IgniteCheckedException: No session found is thrown and takes down
the JVM killing my application. The Ignite server however stays up.

Just to test I tried to revert to the Multicast IP finder but I am now
getting the same error.

I have been able to connect to Ignite other clusters, but not the one local
to the client.

Below is the client configuration.  I am starting up the server using
./ignite.sh ../examples/config/example-ignite.xml -v with the Dynamic Ip
finder comment out
<bean
class="org.apache.ignite.spi.discovery.tcp.ipfinder.multicast.TcpDiscoveryMulticastIpFinder">
and the static un commented out.
<bean
class="org.apache.ignite.spi.discovery.tcp.ipfinder.vm.TcpDiscoveryVmIpFinder">

Any help would be appreciated.  

synchronized (igniteLock){
            if(ignite == null) {
                System.setProperty("java.net.preferIPv4Stack" , "true");
                IgniteConfiguration cfg = new IgniteConfiguration();
                cfg.setClassLoader(WSUtil.class.getClassLoader());
                cfg.setClientMode(true);
                cfg.setPeerClassLoadingEnabled(true);
                TcpDiscoverySpi spi = new TcpDiscoverySpi();
                TcpDiscoveryVmIpFinder ipFinder = new
TcpDiscoveryVmIpFinder();
               
ipFinder.setAddresses(Collections.singletonList("127.0.0.1:47500..47509"));            
                spi.setIpFinder(ipFinder);
                cfg.setDiscoverySpi(spi);
                //start client node
                ignite = Ignition.start(cfg);
            }
        }
 return ignite;

I have my exact xml, config, stack trace and server out put on this stack
overflow post:
https://stackoverflow.com/questions/66127631/ignite-client-crashes-jvm-while-connecting-to-cluster



--
Sent from: http://apache-ignite-users.70518.x6.nabble.com/
akorensh akorensh
Reply | Threaded
Open this post in threaded view
|

Re: Ignite Client crashes JVM while Connecting to cluster

Hi,

Make sure you are using the java.net.preferIPv4Stack property on the server
side as well.

Check your firewall config, to make sure that all listed ports are open.

The issue is w/the communication SPI which, by default is using 47100 and up
port range see:
https://ignite.apache.org/docs/latest/clustering/network-configuration#communication

Error in question:
    Caused by: class org.apache.ignite.IgniteCheckedException: No session
found
            at
org.apache.ignite.spi.communication.tcp.TcpCommunicationSpi.createNioSession(TcpCommunicationSpi.java:3986)




--
Sent from: http://apache-ignite-users.70518.x6.nabble.com/