How to use spark-2.4 module in Ignite 2.8?

classic Classic list List threaded Threaded
5 messages Options
Stefan Miklosovic Stefan Miklosovic
Reply | Threaded
Open this post in threaded view
|

How to use spark-2.4 module in Ignite 2.8?

Hi,

I want to try spark-2.4 module committed recently but I do not see
spark-2.4 directory in optional dir after I build whole Ignite
distribution.

I am building like this:

mvn clean install -Pall-java,all-scala,licenses -DskipTests && mvn
initialize -Prelease

Why is there just "spark" but not "spark-2.4" even "spark-2.4" is in
all-scala profile?

Cheers
dmagda dmagda
Reply | Threaded
Open this post in threaded view
|

Re: How to use spark-2.4 module in Ignite 2.8?

Alexey, Nikolay,

Could you please step in and shed some light on what has changed with Spark? Probably, that's an issue that needs to be addressed before the release.

-
Denis


On Wed, Dec 18, 2019 at 9:26 AM Stefan Miklosovic <[hidden email]> wrote:
Hi,

I want to try spark-2.4 module committed recently but I do not see
spark-2.4 directory in optional dir after I build whole Ignite
distribution.

I am building like this:

mvn clean install -Pall-java,all-scala,licenses -DskipTests && mvn
initialize -Prelease

Why is there just "spark" but not "spark-2.4" even "spark-2.4" is in
all-scala profile?

Cheers
zaleslaw zaleslaw
Reply | Threaded
Open this post in threaded view
|

Re: How to use spark-2.4 module in Ignite 2.8?

Hi, I've found a bug in pom. It will be fixed on next week in master and release branches.
Thank for the message!

ср, 18 дек. 2019 г. в 22:11, Denis Magda <[hidden email]>:
Alexey, Nikolay,

Could you please step in and shed some light on what has changed with Spark? Probably, that's an issue that needs to be addressed before the release.

-
Denis


On Wed, Dec 18, 2019 at 9:26 AM Stefan Miklosovic <[hidden email]> wrote:
Hi,

I want to try spark-2.4 module committed recently but I do not see
spark-2.4 directory in optional dir after I build whole Ignite
distribution.

I am building like this:

mvn clean install -Pall-java,all-scala,licenses -DskipTests && mvn
initialize -Prelease

Why is there just "spark" but not "spark-2.4" even "spark-2.4" is in
all-scala profile?

Cheers
zaleslaw zaleslaw
Reply | Threaded
Open this post in threaded view
|

Re: How to use spark-2.4 module in Ignite 2.8?

In reply to this post by Stefan Miklosovic
I've fixed this issue in master and release branch, it works locally on my
machine well
https://issues.apache.org/jira/browse/IGNITE-12534

Try to repeat with the updated master!



--
Sent from: http://apache-ignite-users.70518.x6.nabble.com/
dmagda dmagda
Reply | Threaded
Open this post in threaded view
|

Re: How to use spark-2.4 module in Ignite 2.8?

Alex, perfect, thanks for putting the fix on the release train!

-
Denis


On Tue, Jan 14, 2020 at 3:18 AM zaleslaw <[hidden email]> wrote:
I've fixed this issue in master and release branch, it works locally on my
machine well
https://issues.apache.org/jira/browse/IGNITE-12534

Try to repeat with the updated master!



--
Sent from: http://apache-ignite-users.70518.x6.nabble.com/