Getting Started Error

classic Classic list List threaded Threaded
4 messages Options
pgarg pgarg
Reply | Threaded
Open this post in threaded view
|

Getting Started Error

asked by vladimir

I am doing the steps of Getting started ( http://apacheignite.readme.io/v1.0/docs/getting-started ). But I get this error: Exception Caused by: class org.apache.ignite.IgniteException: Failed to find class with given class loader for unmarshalling

-----
This post is migrated from now discontinued Apache Ignite forum at
http://apacheignite.readme.io/v1.0/discuss
pgarg pgarg
Reply | Threaded
Open this post in threaded view
|

Re: Getting Started Error

commented by dmitriy setrakyan

Perhaps you need to move some library from libs/optional to libs. Can you paste the full stack trace here?

-----
This post is migrated from now discontinued Apache Ignite forum at
http://apacheignite.readme.io/v1.0/discuss
pgarg pgarg
Reply | Threaded
Open this post in threaded view
|

Re: Getting Started Error

commented by vladimir

the problem arises when I have more than one node in the cluster and call: try (Ignite ignite = Ignition.start())

if I call try (Ignite ignite = Ignition.start("examples/config/example-compute.xml")) it works!

-----
This post is migrated from now discontinued Apache Ignite forum at
http://apacheignite.readme.io/v1.0/discuss
pgarg pgarg
Reply | Threaded
Open this post in threaded view
|

Re: Getting Started Error

commented by dmitriy setrakyan

The reason is that your classes are not deployed on remote nodes and peer-class-loading is disabled by default.

You can either copy your application Jar files to the "libs" folder on every node, or turn on peer-class-loading.

For more information about peer-class-loading, please refer to Zero Deployment.

-----
This post is migrated from now discontinued Apache Ignite forum at
http://apacheignite.readme.io/v1.0/discuss