Geospatial module's JTS dependency license change

classic Classic list List threaded Threaded
3 messages Options
jcheckdev jcheckdev
Reply | Threaded
Open this post in threaded view
|

Geospatial module's JTS dependency license change

Hello,

Currently the geospatial module is not included in binary distributions due to JTS dependency being LGPL according to: https://apacheignite-sql.readme.io/docs/geospatial-support.

It seems that JTS project has changed hands to Eclipse's LocationTech and is under EPL 1.0 and EDL 1.0 licenses: https://github.com/locationtech/jts

Is it possible for this module to be included in a future release with this license change? It would greatly appreciated if possible.

Thanks

ilya.kasnacheev ilya.kasnacheev
Reply | Threaded
Open this post in threaded view
|

Re: Geospatial module's JTS dependency license change

Hello!

Can you please create a JIRA issue about this? I'm pretty sure we can look into it.

Regards,
--
Ilya Kasnacheev


пн, 4 февр. 2019 г. в 07:50, [hidden email] <[hidden email]>:
Hello,

Currently the geospatial module is not included in binary distributions due to JTS dependency being LGPL according to: https://apacheignite-sql.readme.io/docs/geospatial-support.

It seems that JTS project has changed hands to Eclipse's LocationTech and is under EPL 1.0 and EDL 1.0 licenses: https://github.com/locationtech/jts

Is it possible for this module to be included in a future release with this license change? It would greatly appreciated if possible.

Thanks

jcheckdev jcheckdev
Reply | Threaded
Open this post in threaded view
|

Re: Geospatial module's JTS dependency license change


I have not contributed before so I'm not familiar with the proper process. I made a JIRA account: jcheckdev. Does my JIRA account need approval or can I just create the issue?

Thanks

On 2019/02/04 06:54:02, Ilya Kasnacheev <[hidden email]> wrote:

> Hello!
>
> Can you please create a JIRA issue about this? I'm pretty sure we can look
> into it.
>
> Regards,
> --
> Ilya Kasnacheev
>
>
> пн, 4 февр. 2019 г. в 07:50, [hidden email] <[hidden email]>:
>
> > Hello,
> >
> > Currently the geospatial module is not included in binary distributions
> > due to JTS dependency being LGPL according to:
> > https://apacheignite-sql.readme.io/docs/geospatial-support.
> >
> > It seems that JTS project has changed hands to Eclipse's LocationTech and
> > is under EPL 1.0 and EDL 1.0 licenses: https://github.com/locationtech/jts
> >
> > Is it possible for this module to be included in a future release with
> > this license change? It would greatly appreciated if possible.
> >
> > Thanks
> >
> >
>