Are CPU Metrics logged by Ignite correct?

classic Classic list List threaded Threaded
6 messages Options
Mat Mat
Reply | Threaded
Open this post in threaded view
|

Are CPU Metrics logged by Ignite correct?

Ignite is logging "strange" CPU metrics for me:

Metrics for local node (to disable set 'metricsLogFrequency' to 0)
    ^-- Node [id=c2a76580, name=embedded, uptime=00:01:00.153]
    ^-- H/N/C [hosts=1, nodes=1, CPUs=12]
    ^-- *CPU [cur=-100%, avg=-96.15%, GC=0%]*
    ^-- PageMemory [pages=200]
    ^-- Heap [used=337MB, free=95.84%, comm=508MB]
    ^-- Off-heap [used=0MB, free=99.89%, comm=592MB]
    ^--   DefaultDataRegion region [used=0MB, free=100%, comm=512MB]
    ^--   sysMemPlc region [used=0MB, free=99.21%, comm=40MB]
    ^--   TxLog region [used=0MB, free=100%, comm=40MB]
    ^-- Outbound messages queue [size=0]
    ^-- Public thread pool [active=0, idle=0, qSize=0]
    ^-- System thread pool [active=0, idle=2, qSize=0]


I have tested 2.8.1, 2.8.0 and 2.7.0 as well as multiple environment and
bottom line CPU always show negative values that cannot be correlated with
the real cpu usage. Am I missing something?



--
Sent from: http://apache-ignite-users.70518.x6.nabble.com/
ezhuravlev ezhuravlev
Reply | Threaded
Open this post in threaded view
|

Re: Are CPU Metrics logged by Ignite correct?

Hi,

What OS and java version do you use?

Evgenii

пт, 24 июл. 2020 г. в 12:32, Mat <[hidden email]>:
Ignite is logging "strange" CPU metrics for me:

Metrics for local node (to disable set 'metricsLogFrequency' to 0)
    ^-- Node [id=c2a76580, name=embedded, uptime=00:01:00.153]
    ^-- H/N/C [hosts=1, nodes=1, CPUs=12]
    ^-- *CPU [cur=-100%, avg=-96.15%, GC=0%]*
    ^-- PageMemory [pages=200]
    ^-- Heap [used=337MB, free=95.84%, comm=508MB]
    ^-- Off-heap [used=0MB, free=99.89%, comm=592MB]
    ^--   DefaultDataRegion region [used=0MB, free=100%, comm=512MB]
    ^--   sysMemPlc region [used=0MB, free=99.21%, comm=40MB]
    ^--   TxLog region [used=0MB, free=100%, comm=40MB]
    ^-- Outbound messages queue [size=0]
    ^-- Public thread pool [active=0, idle=0, qSize=0]
    ^-- System thread pool [active=0, idle=2, qSize=0]


I have tested 2.8.1, 2.8.0 and 2.7.0 as well as multiple environment and
bottom line CPU always show negative values that cannot be correlated with
the real cpu usage. Am I missing something?



--
Sent from: http://apache-ignite-users.70518.x6.nabble.com/
Raymond Wilson Raymond Wilson
Reply | Threaded
Open this post in threaded view
|

Re: Are CPU Metrics logged by Ignite correct?

We see the same things on Windows/Linux, Coretto v11, and in K8s containers. Ignite 2.8.0  

On Sat, Jul 25, 2020 at 7:44 AM Evgenii Zhuravlev <[hidden email]> wrote:
Hi,

What OS and java version do you use?

Evgenii

пт, 24 июл. 2020 г. в 12:32, Mat <[hidden email]>:
Ignite is logging "strange" CPU metrics for me:

Metrics for local node (to disable set 'metricsLogFrequency' to 0)
    ^-- Node [id=c2a76580, name=embedded, uptime=00:01:00.153]
    ^-- H/N/C [hosts=1, nodes=1, CPUs=12]
    ^-- *CPU [cur=-100%, avg=-96.15%, GC=0%]*
    ^-- PageMemory [pages=200]
    ^-- Heap [used=337MB, free=95.84%, comm=508MB]
    ^-- Off-heap [used=0MB, free=99.89%, comm=592MB]
    ^--   DefaultDataRegion region [used=0MB, free=100%, comm=512MB]
    ^--   sysMemPlc region [used=0MB, free=99.21%, comm=40MB]
    ^--   TxLog region [used=0MB, free=100%, comm=40MB]
    ^-- Outbound messages queue [size=0]
    ^-- Public thread pool [active=0, idle=0, qSize=0]
    ^-- System thread pool [active=0, idle=2, qSize=0]


I have tested 2.8.1, 2.8.0 and 2.7.0 as well as multiple environment and
bottom line CPU always show negative values that cannot be correlated with
the real cpu usage. Am I missing something?



--
Sent from: http://apache-ignite-users.70518.x6.nabble.com/


--

Raymond Wilson
Solution Architect, Civil Construction Software Systems (CCSS)
11 Birmingham Drive | Christchurch, New Zealand
<a href="tel:+64-21-2013317" style="background-color:transparent;color:rgb(54,53,69)" target="_blank">+64-21-2013317 Mobile
[hidden email]
Mat Mat
Reply | Threaded
Open this post in threaded view
|

Re: Are CPU Metrics logged by Ignite correct?

Tested with Windows and Linux K8 containers all on Java 11.



--
Sent from: http://apache-ignite-users.70518.x6.nabble.com/
ezhuravlev ezhuravlev
Reply | Threaded
Open this post in threaded view
|

Re: Are CPU Metrics logged by Ignite correct?

Hi,

It's a known issue related to the java11: https://issues.apache.org/jira/browse/IGNITE-13306

Evgenii

пн, 27 июл. 2020 г. в 03:17, Mat <[hidden email]>:
Tested with Windows and Linux K8 containers all on Java 11.



--
Sent from: http://apache-ignite-users.70518.x6.nabble.com/
Raymond Wilson Raymond Wilson
Reply | Threaded
Open this post in threaded view
|

Re: Are CPU Metrics logged by Ignite correct?

I tried the argument fix proposed in the Jira ticket on Coretto - this results in a JVM failure with an unknown option message.

On Wed, Jul 29, 2020 at 11:59 AM Evgenii Zhuravlev <[hidden email]> wrote:
Hi,

It's a known issue related to the java11: https://issues.apache.org/jira/browse/IGNITE-13306

Evgenii

пн, 27 июл. 2020 г. в 03:17, Mat <[hidden email]>:
Tested with Windows and Linux K8 containers all on Java 11.



--
Sent from: http://apache-ignite-users.70518.x6.nabble.com/


--

Raymond Wilson
Solution Architect, Civil Construction Software Systems (CCSS)
11 Birmingham Drive | Christchurch, New Zealand
<a href="tel:+64-21-2013317" style="background-color:transparent;color:rgb(54,53,69)" target="_blank">+64-21-2013317 Mobile
[hidden email]