Apache Ignite Install As Service error

classic Classic list List threaded Threaded
10 messages Options
ApacheUser ApacheUser
Reply | Threaded
Open this post in threaded view
|

Apache Ignite Install As Service error

Hi Team,

I am trying to Install Apache Ignite as Service one node goes well but coupe
of nodes throw the below message and they don't allow connection.

Process: 16828 ExecStartPre=/usr/bin/mkdir /var/run/apache-ignite
(code=exited, status=1/FAILURE)


In Service mode is there anyway I can run ignitevisorcmd.sh  and see the
topology etc?

thanks



--
Sent from: http://apache-ignite-users.70518.x6.nabble.com/
ApacheUser ApacheUser
Reply | Threaded
Open this post in threaded view
|

Re: Apache Ignite Install As Service error

the service is running but cant access, full message below
[]# systemctl status [hidden email]
[hidden email] - Apache Ignite In-Memory
Computing Platform Service
   Loaded: loaded (/etc/systemd/system/apache-ignite@.service; enabled;
vendor preset: disabled)
   Active: active (running) since Mon 2018-07-09 15:40:49 GMT; 2s ago
  Process: 16838 ExecStart=/usr/share/apache-ignite/bin/service.sh start %i
(code=exited, status=0/SUCCESS)
  Process: 16833 ExecStartPre=/usr/bin/env bash
/usr/share/apache-ignite/bin/service.sh set-firewall (code=exited,
status=0/SUCCESS)
  Process: 16830 ExecStartPre=/usr/bin/chown ignite:ignite
/var/run/apache-ignite (code=exited, status=0/SUCCESS)
  Process: 16828 ExecStartPre=/usr/bin/mkdir /var/run/apache-ignite
(code=exited, status=1/FAILURE)
 Main PID: 16840 (ignite.sh)
   CGroup:
/system.slice/system-apache\x2dignite.slice/[hidden email]
           ├─16840 /bin/bash /usr/share/apache-ignite/bin/ignite.sh
/etc/apache-ignite/default-config.xml
           └─16929 /usr/bin/java -Xms1g -Xmx1g -server -XX:+AggressiveOpts
-XX:MaxMetaspaceSize=256m -DIGNITE_QUIET=true
-DIGNITE_SUCCESS_FILE=/usr/share/apache-ignite/work/ignite...

Jul 09 15:40:49 ccrc_spark_analytic_4 systemd[1]: Starting Apache Ignite
In-Memory Computing Platform Service...
Jul 09 15:40:49 ccrc_spark_analytic_4 systemd[1]: Started Apache Ignite
In-Memory Computing Platform Service.

Thanks





--
Sent from: http://apache-ignite-users.70518.x6.nabble.com/
ilya.kasnacheev ilya.kasnacheev
Reply | Threaded
Open this post in threaded view
|

Re: Apache Ignite Install As Service error

Hello!

What version of package are you using? Since 2.4 there should be a minus
sign before mkdir, which will make it non-essential. Also, I don't
understand why chown is ran before mkdir. Petr, can you chime in by chance?

Regards,




--
Sent from: http://apache-ignite-users.70518.x6.nabble.com/
Petr Ivanov Petr Ivanov
Reply | Threaded
Open this post in threaded view
|

Re: Apache Ignite Install As Service error

Please see current service implementation (available in packages): https://github.com/apache/ignite/blob/master/packaging/rpm/name.service



> On 11 Jul 2018, at 13:20, ilya.kasnacheev <[hidden email]> wrote:
>
> Hello!
>
> What version of package are you using? Since 2.4 there should be a minus
> sign before mkdir, which will make it non-essential. Also, I don't
> understand why chown is ran before mkdir. Petr, can you chime in by chance?
>
> Regards,
>
>
>
>
> --
> Sent from: http://apache-ignite-users.70518.x6.nabble.com/

ApacheUser ApacheUser
Reply | Threaded
Open this post in threaded view
|

Re: Apache Ignite Install As Service error

In reply to this post by ilya.kasnacheev
Hi ilya,

I am using Ignite 2.5, The message pasted from "systemctl status
[hidden email] "command. I did nt run any command.

full message:

]# systemctl status [hidden email]
[hidden email] - Apache Ignite In-Memory
Computing Platform Service
   Loaded: loaded (/etc/systemd/system/apache-ignite@.service; enabled;
vendor preset: disabled)
   Active: active (running) since Mon 2018-07-09 15:36:40 GMT; 2s ago
  Process: 24867 ExecStart=/usr/share/apache-ignite/bin/service.sh start %i
(code=exited, status=0/SUCCESS)
  Process: 24862 ExecStartPre=/usr/bin/env bash
/usr/share/apache-ignite/bin/service.sh set-firewall (code=exited,
status=0/SUCCESS)
  Process: 24858 ExecStartPre=/usr/bin/chown ignite:ignite
/var/run/apache-ignite (code=exited, status=0/SUCCESS)
  Process: 24856 ExecStartPre=/usr/bin/mkdir /var/run/apache-ignite
(code=exited, status=1/FAILURE)
 Main PID: 24869 (ignite.sh)
   CGroup:
/system.slice/system-apache\x2dignite.slice/[hidden email]
           ├─24869 /bin/bash /usr/share/apache-ignite/bin/ignite.sh
/etc/apache-ignite/default-config.xml
           └─24958 /usr/bin/java -Xms1g -Xmx1g -server -XX:+AggressiveOpts
-XX:MaxMetaspaceSize=256m -DIGNITE_QUIET=true
-DIGNITE_SUCCESS_FILE=/usr/share/apache-ignite/work/ignite...




Thanks



--
Sent from: http://apache-ignite-users.70518.x6.nabble.com/
ilya.kasnacheev ilya.kasnacheev
Reply | Threaded
Open this post in threaded view
|

Re: Apache Ignite Install As Service error

Hello!

Can you please share your /etc/systemd/system/apache-ignite@.service file?

And also the result of dpkg -S /etc/systemd/system/apache-ignite@.service command execution?

Regards,

--
Ilya Kasnacheev

2018-07-11 18:29 GMT+03:00 ApacheUser <[hidden email]>:
Hi ilya,

I am using Ignite 2.5, The message pasted from "systemctl status
apache-ignite@default-config.xml "command. I did nt run any command.

full message:

]# systemctl status apache-ignite@default-config.xml
● apache-ignite@default-config.xml.service - Apache Ignite In-Memory
Computing Platform Service
   Loaded: loaded (/etc/systemd/system/apache-ignite@.service; enabled;
vendor preset: disabled)
   Active: active (running) since Mon 2018-07-09 15:36:40 GMT; 2s ago
  Process: 24867 ExecStart=/usr/share/apache-ignite/bin/service.sh start %i
(code=exited, status=0/SUCCESS)
  Process: 24862 ExecStartPre=/usr/bin/env bash
/usr/share/apache-ignite/bin/service.sh set-firewall (code=exited,
status=0/SUCCESS)
  Process: 24858 ExecStartPre=/usr/bin/chown ignite:ignite
/var/run/apache-ignite (code=exited, status=0/SUCCESS)
  Process: 24856 ExecStartPre=/usr/bin/mkdir /var/run/apache-ignite
(code=exited, status=1/FAILURE)
 Main PID: 24869 (ignite.sh)
   CGroup:
/system.slice/system-apache\x2dignite.slice/apache-ignite@default-config.xml.service
           ├─24869 /bin/bash /usr/share/apache-ignite/bin/ignite.sh
/etc/apache-ignite/default-config.xml
           └─24958 /usr/bin/java -Xms1g -Xmx1g -server -XX:+AggressiveOpts
-XX:MaxMetaspaceSize=256m -DIGNITE_QUIET=true
-DIGNITE_SUCCESS_FILE=/usr/share/apache-ignite/work/ignite...




Thanks

Petr Ivanov Petr Ivanov
Reply | Threaded
Open this post in threaded view
|

Re: Apache Ignite Install As Service error

In reply to this post by ApacheUser
That’s normal output of running service.



> On 11 Jul 2018, at 18:29, ApacheUser <[hidden email]> wrote:
>
> Hi ilya,
>
> I am using Ignite 2.5, The message pasted from "systemctl status
> [hidden email] "command. I did nt run any command.
>
> full message:
>
> ]# systemctl status [hidden email]
> ● [hidden email] - Apache Ignite In-Memory
> Computing Platform Service
>   Loaded: loaded (/etc/systemd/system/apache-ignite@.service; enabled;
> vendor preset: disabled)
>   Active: active (running) since Mon 2018-07-09 15:36:40 GMT; 2s ago
>  Process: 24867 ExecStart=/usr/share/apache-ignite/bin/service.sh start %i
> (code=exited, status=0/SUCCESS)
>  Process: 24862 ExecStartPre=/usr/bin/env bash
> /usr/share/apache-ignite/bin/service.sh set-firewall (code=exited,
> status=0/SUCCESS)
>  Process: 24858 ExecStartPre=/usr/bin/chown ignite:ignite
> /var/run/apache-ignite (code=exited, status=0/SUCCESS)
>  Process: 24856 ExecStartPre=/usr/bin/mkdir /var/run/apache-ignite
> (code=exited, status=1/FAILURE)
> Main PID: 24869 (ignite.sh)
>   CGroup:
> /system.slice/system-apache\x2dignite.slice/[hidden email]
>           ├─24869 /bin/bash /usr/share/apache-ignite/bin/ignite.sh
> /etc/apache-ignite/default-config.xml
>           └─24958 /usr/bin/java -Xms1g -Xmx1g -server -XX:+AggressiveOpts
> -XX:MaxMetaspaceSize=256m -DIGNITE_QUIET=true
> -DIGNITE_SUCCESS_FILE=/usr/share/apache-ignite/work/ignite...
>
>
>
>
> Thanks
>
>
>
> --
> Sent from: http://apache-ignite-users.70518.x6.nabble.com/

ApacheUser ApacheUser
Reply | Threaded
Open this post in threaded view
|

Re: Apache Ignite Install As Service error

In reply to this post by ilya.kasnacheev
Hi,

/etc/systemd/system/apache-ignite@.service:

[Unit]
Description=Apache Ignite In-Memory Computing Platform Service
After=syslog.target network.target

[Service]
Type=forking
User=ignite
WorkingDirectory=/usr/share/apache-ignite/work
PermissionsStartOnly=true
ExecStartPre=-/usr/bin/mkdir /var/run/apache-ignite
ExecStartPre=-/usr/bin/chown ignite:ignite /var/run/apache-ignite
ExecStartPre=-/usr/bin/env bash /usr/share/apache-ignite/bin/service.sh
set-firewall
ExecStart=/usr/share/apache-ignite/bin/service.sh start %i
PIDFile=/var/run/apache-ignite/%i.pid

[Install]
WantedBy=multi-user.target

I am using Redhat EnterPrise Linux 7.5

thanks





--
Sent from: http://apache-ignite-users.70518.x6.nabble.com/
ApacheUser ApacheUser
Reply | Threaded
Open this post in threaded view
|

Re: Apache Ignite Install As Service error

In reply to this post by Petr Ivanov
the message from the above out put:
Process: 24856 ExecStartPre=/usr/bin/mkdir /var/run/apache-ignite
(code=exited, status=1/FAILURE)

is it normal?  Not able to connect to the nodes for which I got this
mesaage(code=exited, status=1/FAILURE)

thanks




--
Sent from: http://apache-ignite-users.70518.x6.nabble.com/
ilya.kasnacheev ilya.kasnacheev
Reply | Threaded
Open this post in threaded view
|

Re: Apache Ignite Install As Service error

Hello!

The minus sign prefix in ExecStartPre should avoid failing start when error is encountered.

I don't understand why it does in your specific case. Perhaps you should ask Red Hat. Or wait for 2.6 release where this command is amended.

Regards,

--
Ilya Kasnacheev

2018-07-11 19:07 GMT+03:00 ApacheUser <[hidden email]>:
the message from the above out put:
Process: 24856 ExecStartPre=/usr/bin/mkdir /var/run/apache-ignite
(code=exited, status=1/FAILURE)

is it normal?  Not able to connect to the nodes for which I got this
mesaage(code=exited, status=1/FAILURE)

thanks