Apache Ignite 1.4.0 with JDK6

classic Classic list List threaded Threaded
2 messages Options
Kobe Kobe
Reply | Threaded
Open this post in threaded view
|

Apache Ignite 1.4.0 with JDK6


I am constrained to use JDK6 with a project. I have been trying to integrate Apache Ignite (1.4.0) in this project. I have run into this issue: org.apache.ignite.Ignite seem sot extend java.lang.AutoCloseable.

 java.lang.AutoCloseable is an artifact of JDK7 and is not supported in JDK6.

Am I put of luck? Must I use JDK7+ to use Ignite?

thanks,

/Kobe
prem prem
Reply | Threaded
Open this post in threaded view
|

Re: Apache Ignite 1.4.0 with JDK6

Yes Kobe jdk 7 is minimum requirement

Sent from my iPhone

> On Jan 24, 2016, at 9:34 PM, Kobe <[hidden email]> wrote:
>
>
> I am constrained to use JDK6 with a project. I have been trying to integrate
> Apache Ignite (1.4.0) in this project. I have run into this issue:
> org.apache.ignite.Ignite seem sot extend java.lang.AutoCloseable.
>
> java.lang.AutoCloseable is an artifact of JDK7 and is not supported in
> JDK6.
>
> Am I put of luck? Must I use JDK7+ to use Ignite?
>
> thanks,
>
> /Kobe
>
>
>
>
> --
> View this message in context: http://apache-ignite-users.70518.x6.nabble.com/Apache-Ignite-1-4-0-with-JDK6-tp2684.html
> Sent from the Apache Ignite Users mailing list archive at Nabble.com.